User Interface is Garbage

At first glance, this website appears intuitive, efficient, and user-friendly. However, when I try to create a survey using a template, I was taken to a pre-contructed template of questions that I could would not accept any commands such as "Delete, add, copy" I was unable to edit them in any way. When I tried to create a brand new survey, I was unable to EDIT IT IN ANY WAY. When I tried to go to the help section, I had to sign in AGAN even though I was already signed in. If these problems didn't exists, I would bump you guys up to a 5-star rating easily.

1 Like

Hi Thompson,

Welcome to the SurveySparrow Community.

We apologize for the inconvenience you are experiencing with our platform. I request that you record the issue you are experiencing while creating the survey using the link and share it so we can look into it.

Also, please let me know your email address, and would you be so kind as to provide access to your account? (Navigate to Main Settings--Account Access--Approve Account Access)