Creating new contacts in HubSpot after survey completion

Hi all,

I’m trying to configure a HubSpot integration with my survey. Basically, I want to create a contact in HubSpot for each survey respondent, and I also want to add the contacts to have a property such as “Has completed the survey”, in order to identify survey respondents in HubSpot and be able to add them to a list.

However :

  1. Despite associating SurveySparrow fields with my HubSpot fields (essentially First Name, Last Name and email address), it doesn’t seem to work - it makes me think that the integration is only meant to update existing contacts and not create new ones.

  2. For the “Has completed survey” property, I can’t seem to figure out how to create a hidden field and enter a value in it.

Any help would be appreciated. Thanks in advance!

Hey @Cedra ! Thank you posting your query! :slight_smile:

  1. You should definitely be able to create new contacts on HubSpot, Cedra! No worries, we’re checking it for you from the backend. Will keep you posted of what went wrong.
  2. You can simply create a new variable, map it to the Has completed survey property and pass a default value. Guess this will work. Please let us know if it goes the other way.

We’re more than happy to help you.

Hey @Kaushik_Vikram_Balaji , thanks for your answer!

I have created a new variable for the Has completed survey property - however, I still need to wait for 1 to be resolved in order to try it out and see if it works.

Looking forward to hearing from you!

1 Like

Got it! Our support team will get in touch with you regarding this over an email. They’ll help you with the further steps. Together, let’s resolve this :slight_smile:

1 Like

Hello! Any update on this? :slight_smile:

Hey @Cedra! I’ll keep you posted on this. Thank you :slight_smile:

1 Like

Hello @Kaushik_Vikram_Balaji!

Do you have an update on this?

I need to start sending out the questionnaire ASAP and can’t do that until the HubSpot integration is set up and working :frowning:

Thanks!

Hi @Cedra

Sorry for the late response, we were away due to the long weekend.

We analyzed and found that for all of the submissions, contact id null. Which means submissions are not linked to contact.

Are the users taking the survey via weblink?
Also, are you free for a screen share session over zoom to discuss this?

Cheers
Jay

Hi @Jayesh_Urath,

No issue at all.

Would be happy to discuss that over Zoom this afternoon if that’s okay by you :slight_smile:

Hi @Cedra,

Thanks for the reply, I have left a placeholder in your calendar.
Feel free to let me know if the time doesn’t suit you, will be glad to reschedule.

Cheers
Jay

This issue has been solved following a call with @Jayesh_Urath and Robin! Thank you all for your help :slight_smile:

Glad to know it wasn’t a bug, but a matter of Field Type selection on my end. It seems to work perfectly now!

1 Like

@Cedra
Thanks a lot for your time over the Zoom.
Glad that the issue is resolved.
Feel free to reach out for further assistance.

Cheers
Jay

1 Like